Tag Archives: sysprep

Windows: Sysprep error “Machine is in an invalid state or we couldn’t update the recorded state.”

Hi,

when during the execution of sysprep the error message “A fatal error occured while trying to sysprep machine” is shown check the setupact.log and setuperr.log in “C:\windows\system32\sysprep\panther”.
Continue reading Windows: Sysprep error “Machine is in an invalid state or we couldn’t update the recorded state.”

Advertisment to support michlstechblog.info

Windows: Sysprep fails with “Package xy installed for a user, but not provisioned for all users”

Hi,

when you call sysprep and it fails (logfile C:\windows\System32\sysprep\panther\setuperr.log) with an error “Package xy installed for a user, but not provisioned for all users” you have to remove those packages from the user profile.

Continue reading Windows: Sysprep fails with “Package xy installed for a user, but not provisioned for all users”

VMware: Computer Account is disabled after deploying Windows Clients

Hello,

last week I had to deploy 25virtual Windows (XP) Clients an on VMware ESX Cluster. One of the requirements was that the clients must be member of a Windows Active Directory.

After setting up vCenter (copy sysprep) I installed a reference Windows XP vm, convert them to a template and defined a Customization Specification like this:

Initial Customization Specification

During the cloning process, by using the template with the recently created custom spec, the domain join always fails and the Computer Account was disabled at each try.

Ok, now I tried modify some parameter of the Custom Specification:

  • Changing the Domain from fqdn to the NetBIOS Domain “SUB”
  • Altered the Username to SUB\joinuser or joinuser@SUB or joinuser@sub.domain.org

Continue reading VMware: Computer Account is disabled after deploying Windows Clients